
Ms-Access Forms 
Form is an object in a desktop database designed primarily for data input or display or for control of 
application execution. You use forms to customize the presentation of data that your application extracts 
from queries or tables. 

 Forms are used for entering, modifying, and viewing records. 
 The reason forms are used so often is that they are an easy way to guide people toward entering 

data correctly. 
 When you enter information into a form in Access, the data goes exactly where the database 

designer wants it to go in one or more related tables. 
In a database context, a form is a window or screen that contains numerous fields, or spaces to enter 
data. Each field holds a field label so that any user who views the form gets an idea of its contents. A 
form is more user friendly than generating queries to create tables and insert data into fields. 
Databases like SQL and Oracle do not use built-in forms, employing the query option for data creation 
and manipulation instead. This makes querying knowledge essential to handling these databases. 
Microsoft Access, however, uses forms for data entry, making it more user friendly than its counterparts. 
The fields and field labels are organized in a logical manner for easy form access and manipulation. 
While making an entry into fields of a form, it is important to be careful about the field types, which are 
generally set when the form is created. As such, an attempt to enter values that do not satisfy the field 
constraints will fail. For instance, a field with a field type "not null" does not take null values and cannot be 
left blank. Some fields may also have table relationships connected by a foreign key; any alteration of 
such a field in a form needs special care. 
Kinds of Forms in Access 
The two basic types of forms − 

1. Bound forms 
2. Unbound forms 

Bound Forms 
 Bound forms are connected to some underlying data source such as a table, query, or SQL 

statement. 
 Bound forms are what people typically think of when they think of the purpose of a form. 
 Forms are to be filled out or used to enter or edit data in a database. 
 Examples of bound forms will typically be what users use to enter, view or edit data in a 

database. 
Unbound Forms 

 These forms are not connected to an underlying record or data source. 
 Unbound forms could be dialog boxes, switch boards, or navigation forms. 
 In other words, unbound forms are typically used to navigate or interact with the database at 

large, as opposed to the data itself. 
Types of Bound Forms 



There are many types of bound forms you can create in Access  − 
1. Single Item Form 

This is the most popular one and this is where the records are displayed — one record at a time. 
2. Multiple Item Form 

This displays multiple records at a time from that bound data source. 
3. Split Form 

The form is divided into halves, either vertically or horizontally. One half displays a single item or record, 
and the other half displays a list or provides a datasheet view of multiple records from the underlying data 
source. 
 

Creating a form 
Access 2007 has several automatic tools for creating forms. These tools are located in the Forms group 
on the Create tab in the Ribbon, as seen below: 

 
 
Access 2007 forms tools include: 

 The Form command makes a basic form, showing a single record at a time. 
 The Split Form command creates a form showing one record on top and includes the Datasheet 

view of the entire source table on the bottom. 
 The Multiple Items command creates a form that shows all records at once, which looks similar 

to the source table in Datasheet view. 
 The Form Wizard is hidden under the More Forms command. It walks you through the process 

of creating more customized forms. 
To create a form using the Form command: 
You can use the Form tool to create a form with a single mouse-click. When you use this tool, all the 
fields from the underlying data source are placed on the form. You can begin using the new form 
immediately, or you can modify it in Layout view or Design view to better suit your needs. 

1. In the Navigation Pane, click the table or query that contains the data you want to see on your 
form. 

2. On the Create tab, in the Forms group, click Form. 
3. The new form is created and opens in the object pane. 



Access creates the form and displays it in Layout view. In Layout view, you can make design changes to 
the form while it is displaying data. For example, you can adjust the size of the text boxes to fit the data, if 
necessary. The newly created form has the same name as the source table by default. You can give the 
form a new name by saving the form. You will be prompted to give the form a name. 
Create a blank form in Access 
If the wizard or the form-building tools don't fit your needs, you can use the Blank Form tool to build a 
form. This can be a very quick way to build a form, especially if you plan to put only a few fields on your 
form. 

1. On the Create tab, in the Forms group, click Blank Form button. 
2. Access opens a blank form in Layout view, and displays the Field list pane. 
3. In the Field list pane, click the plus sign (+) next to the table or tables that contain the fields that 

you want to see on the form. 
4. To add a field to the form, double-click it or drag it onto the form. To add several fields at once, 

hold down CTRL and click several fields, and then drag them onto the form at the same time. 
Note: The order of the tables in the Field list pane can change, depending on which part of the form 
is currently selected. If you are not able to add a field to the form, try selecting a different part of the 
form and then try adding the field again. 
5. Use the tools in the Controls group on the Format tab to add a logo, title, page numbers, or the 

date and time to the form. 
6. If you want to add a wider variety of controls to the form, switch to Design view by right-clicking 

the form and then clicking Design View button. You can then use the tools in the Controls group 
on the Design tab. 

Create a split form 
A split form is a new feature in Microsoft Office Access 2007 that gives you two views of your data at the 
same time — a Form view and a Datasheet view.  
The two views are connected to the same data source and are synchronized with each other at all times. 
Selecting a field in one part of the form selects the same field in the other part of the form. You can add, 
edit, or delete data from either part (provided the record source is updateable and you have not 
configured the form to prevent these actions). 
 Working with split forms gives you the benefits of both types of forms in a single form. For example, you 
can use the datasheet portion of the form to quickly locate a record, and then use the form portion to view 
or edit the record. The form portion can serve as an attractive and functional header for the datasheet 
portion. This technique is used in many of the template databases that are available for Office Access 
2007. 
This procedure creates a new split form from scratch. The form is based on a table or query that you 
select from the Navigation Pane or have open in Datasheet view. 

1. In the Navigation Pane, click the table or query that contains the data that you want on your form. 
Or open the table or query in Datasheet view. 

2.  On the Create tab, in the Forms group, click Split Form button. Access creates the form and 
displays it in Layout view. 



Add a field to a split form, or delete a field from a split form 
1. If the Field list pane is not displayed, on the Format tab, in the Tools group, click Add Existing 

Fields. 
2. Locate the field that you want to add, and then drag the field to either the datasheet or the form. 
3. If you drag a field to the datasheet, the field is also added to the form. Likewise, if you drag a field 

to the form, the field is also added to the datasheet. 
4. To delete a field, you must use the form portion of the split form. Click the field to select it, and 

then press DELETE. The field is removed from both the form and the datasheet. 
5.  

Create a form by using the Form Wizard 
To be more selective about what fields appear on your form, you can use the Form Wizard. You can also 
define how the data is grouped and sorted, and you can use fields from more than one table or query, 
provided that you specified the relationships between the tables and queries beforehand. You will need to 
tell the wizard : 

 The table or query on which to base the form. 
 Which fields to use on the form. 
 Form layout to apply. 

To use form wizard : 
1. Select FORM WIZARD 

Open your database if it is not already open. Click the CREATE tab on the Access ribbon, and then select 
FORM WIZARD from the FORMS group. 

 The FORM WIZARD icon.. 
 

2. Select database table and fields 
The Form wizard then opens as the dialog window below.. 



 
The FORM WIZARD dialog. 

On the first page of the form wizard we select which table we are going to use as the DATA SOURCE. 
Since there is only one table in this database so far (ie frmEmployees), it should already be selected for 
us in the TABLES/QUERIES combo box. 
Underneath there is a list of the four fields in your table. You could select each field individually by 
highlighting the field name and clicking the single arrow >. We can, however, select all four just by clicking 
the double arrow >>. Once they have been transferred into the right-hand box they are selected. We can 
now click NEXT to go to the next page of the FORM WIZARD. 

3. Select a  FORM LAYOUT 

 
The FORM LAYOUT page of the FORM WIZARD. 



This is where we choose the FORM LAYOUT. We are going to leave this on the default setting of 
COLUMNAR. Click NEXT again to move onto the last page of the FORM WIZARD. 
4. Enter a FORM TITLE 

 
The FORM TITLE page of the FORM WIZARD. 

Here we are going to choose the name for our form – let’s call it “frmEmployees”. We shall to leave the 
radio button selected for OPEN THE FORM TO ENTER OR VIEW INFORMATION. 
All we need to do now is click FINISH and our form should look like this: 

 
The finished Access Form. 

 
5. Navigate Records via the Access Form 

As you can see, the form opens with the first record in your original table displayed. You can navigate 
through each record using the NAVIGATION BUTTONS at the bottom left of the form window. 



 
NAVIGATION BUTTONS on the Access Form. 

To move to the next record click the right arrow button on the navigation control. To move to the last 
record click the >| button on the navigation control. To move backwards through the recordset use the left 
arrow buttons. You could edit any record from the form, which will update the data in your table. For now, 
though, just try navigating through the three records without changing any data. 

6. Create New Record via Access Form 
Now that you know how to move through the recordset, lets finish off by adding two more records. To do 
this click the star button on the right-hand side of the navigation control (ie >*). This should bring up a 
blank record. Add new data record. Click the star again to bring up a new blank record, and enter new 
data again. When you have finished click X on the form window to close. 
 
Create a form by using the Multiple Items tool 
A multiple item form, also known as a continuous form, lets you show information from more than one 
record at a time. The data is arranged in rows and columns (similar to a datasheet), and multiple records 
are displayed at a time. However, because it is a form, there are more customization options than with a 
datasheet. You can add features such as graphical elements, buttons, and other controls.  
Steps to Create a multiple item form 

1. In the Navigation Pane, click the table or query that contains the data that you want to see on 
the form. 

2. On the Create tab, in the Forms group, click Multiple Items. If Multiple Items is not available, 
click More Forms, and then click Multiple Items. 

Access creates the form and displays it in Layout view. In Layout view, you can make design changes to 
the form while it is displaying data. For example, you can adjust the size of the text boxes to fit the data 

3. To begin using the form, switch to Form view: 
 On the Home tab, in the Views group, click View, and then click Form View. 

 
Modify a Form 

Access forms are much like paper forms: you can use them to enter, edit, or display data. They are based 
on tables. When using a form, you can choose the format, the arrangement, and which fields you want to 
display. 
A view is a way of looking at an Access object. Forms have three views: Form view, Layout view, and 
Design view. You can enter, edit, and view data in Form view. You can modify a form in Layout view or 
Design view. In Layout view, you can see your data, and the form you see closely resembles what your 
form will look like when you view it in Form view. You can make most, but not all, changes to your form in 
Layout view. Design view displays the structure of your form. In this view you cannot see the underlying 
data, but you can perform some tasks in Design view that you cannot perform in Layout view. 



After you create a form, it opens in Layout view, where you can modify it. 
To change the size of a field: 

1. Click a side of the field and drag to change the width of the field. 
2. Click the top or bottom of a field and drag to change the height of a field. 

To move a datasheet: 
1. Click the datasheet to select it. 
2. Click and drag the four-sided arrow in the upper-right corner to move the datasheet. 

To resize a datasheet: 
1. Click the datasheet to select it. 
2. Click a side of the datasheet and drag to change the width. 
3. Click the top or bottom of the datasheet and drag to change the height. 

To apply an AutoFormat: 
The AutoFormat option on the Format tab enables you to apply formats quickly, such as background 
colors, field colors, field label colors, and fonts. 

1. Activate the Format tab. 
2. Click AutoFormat. The AutoFormat menu appears. 
3. Click the format you want to apply. 

To change a form title: 
When you create a form, by default, Access uses the form name as the title. You can change the title. 

1. Activate the Format tab. 
2. Click the Title button. 
3. Type the new title. 

To add the date and time: 
You can easily add the date and time to your form. 

1. Activate the Format tab. 
2. Click the Date and Time button. The Date and Time dialog box appears. Select the date and time 

format you want. The date and time appear on your form. 
Change Fonts and Formats : 

Change fonts and Formats 
Button Shortcut keys function 

Layout view – Format Tab , Font Group 
  Apply a font to the current 

selection. 
  Set the size of the font for the 

current selection. 
 Ctrl-b Bold the current selection. 



 Ctrl-i Italicize the current selection. 
 Ctrl-u Underline the current selection. 
 Ctrl-l Left-align the selection. 
 Ctrl-r Right-align the selection. 
 Ctrl-e Center the selection. 
  Change the font color. 
  Change the background color. 

  
Change the alternating color. For 

example, you can have every 
other row on a datasheet appear 

in an alternating color. 
Layout View—Format Tab, Formatting Group 

  Apply a number format 
  Use a Currency symbol 
  Change to Percent 
  Use thousand separator 
  Increase decimal places 
  decrease decimal places 

Layout View—Format Tab, Gridlines Group 

 
 Add gridlines 

  Change the weight of gridlines 
  Change the style of gridlines 
  Change the color of gridlines 

Layout View—Format Tab, Controls Group 

 
 Add a logo 

  Add or change a title 
  Add a date or time 
  Set line thickness 
  Set line styles 
  Set line color 

   
 
 
You can use options on the Format tab to manually apply individual formats to your report. However, 
before you can apply a format to a field or field label, you must select it. To select a field or field label, 
click it. To select multiple items, hold down the Shift key and then click each item you want to select. A 
box surrounds selected items. 



Navigation Forms 
A navigation form is simply a form that contains a Navigation Control. Access includes a Navigation 
Control that makes it easy to switch between various forms and reports in your database. Navigation 
forms are a great addition to any desktop database. 
Access versions from 97 to 2007 give you the option of creating and using Switchboards to create your 
own navigation system, whilst versions 2007 and 2010 prefer you to customize the new navigation pane 
with your own categories and groups. Another way, though, is to create your own form based navigation 
system. 
If you intend to create your own navigation forms you first need to create one or more table, query, form 
and report to enable you to navigate between these items. Once this is done we can create a new Home 
navigation form. We can arrange that this form opens automatically when the database opens, and if 
you've add command buttons to the form you can click these to move between different tables, queries, 
forms and reports. 
To create a home navigation form : 
First create a new blank form, then save it with a name such as FrmHome. Then with the form still open 
switch to design view. The first step is to label the form, so find your way to the form Controls. In versions 
97-2003 these are in the toolbox, in versions 2007/22010 these are in the Design Tab. Select the label 
control and draw a rectangle shape in the top part of the form. Then type in some text, such as HOME 
FORM. Then click off the label. To apply formatting, click once on the label, and apply formatting such as 
font colour, label background etc then again click off the label. Next we add a command button. 
To do this return to the Form Controls and select the Command Button, or Button, and then draw a button 
rectangle under the heading on the form. When you release the mouse the Button wizard launches to 
help you apply an action to the button. So choose Form Action, click Next, then choose Open Form and 
again click Next. Now choose one of your existing forms and click Next. 
Accept the default to show all records and click Next. Select Text for the button, and enter some 
appropriate text, such as the name of the form you're opening and again click Next. Then type in a name 
for to button such as the target form name click Finish to complete. Then save to form and switch to form 
view. Test the button by clicking it, and the target form should open. 
You might like to add a button in the target form, in design view, to open the Home Form by following the 
same steps as above. Once completed save the form and return to form view and test the button. The 
Home Form should open. So you can build up a series of buttons on the Home form to open other forms. 
On each of the other forms you can add a Home button, so you can then navigate between buttons 
simply by clicking a button on the Home form. 
You'll see from the options in the Button wizard that you can also open tables, queries and reports as well 
as forms, so you can add buttons on the Home form to open any other item in your database. 
Add a form or report to a navigation form 

1. If the Navigation Pane is not already displayed, press F11 to display it. 
2. Ensure that the navigation form is open in Layout View by right-clicking it in the Navigation Pane, 

and then clicking Layout View. 
3. Drag the form or report from the Navigation Pane to the [Add New] button. 



4. Access creates the new navigation button and displays the form or report in the object pane. 
Edit the label at the top of the navigation form 

1. When you create a new navigation form, Access adds the label “Navigation Form” to the form 
header by default. To edit this label: 

2. Open the form in Layout View by right-clicking it in the Navigation Pane, and then clicking Layout 
View. 

3. Click the label in the form header once to select it, and then again to place the cursor in the label. 
4. Edit the label to suit your needs, and then press ENTER. 

Edit the form caption 
The form caption is the text that appears on the document tab above the form (or in the window title bar if 
you have set the database to display objects as overlapping windows). To edit the form caption: 

1. Open the form in Layout View by right-clicking it in the Navigation Pane, and then clicking Layout 
View. 

2. Right click on the form header near the top of the form, and then click Form Properties. 
3. In the Property Sheet task pane, on the All tab, edit the Caption property to suit your needs. 

Apply an Office Theme to a database 
Office Themes provide a quick way to change all of the colors and fonts that are used in a database. 
These themes apply to all objects in the database, not just the one you currently have open. 

1. Open any form or report in Layout View by right-clicking it in the Navigation Pane, and then 
clicking Layout View. 

2. On the Design tab, use the options in the Themes group to apply different color and font themes 
to the database. 

3. To only change colors without affecting fonts, choose an item from the Colors gallery. 
4. To only change fonts without affecting colors, choose an item from the Fonts gallery. 
5. To change both colors and fonts, choose an item from the Themes gallery. In this gallery, you can 

hover over each item to see a live preview of the theme, and then click one to apply it. 
Change the color or shape of a navigation button 
Quick Styles enable you to quickly change the color or shape of navigation buttons. You can apply unique 
styles to each button, or apply the same style to all of the buttons. 

1. Open the navigation form in Layout view by right-clicking it in the Navigation Pane, and then 
clicking Layout View. 

2. Select the navigation button or buttons that you want to change. 
3. Use the commands in the Control Formatting group to apply the styles you want. 

Set the navigation form as the default display form 
Because a navigation form is often used as a switchboard or “home page” for a database, it makes sense 
to display it by default each time that the database is opened. Also, because the Access Navigation Pane 
is not available in a browser, specifying a default Web Display Form is a very important step in creating a 
Web database. 



Use this procedure to set the navigation form as the default display form. 
1. On the File tab, under Help, click Options. 
2. Click Current Database. 
3. To set the default form that is displayed when you open the database in Access, under 

Application Options, select the form from the Display Form list. 
 

MS – Access 2007 : Combo  box 
When entering data on forms, it is often quicker and easier to select a value from a list than to remember 
a value to type. A list of choices also helps ensure that the value that’s entered in a field is appropriate. 
When you use a combo box in an Access form, all you see is a text box that doesn’t display the list until 
you click the drop-down arrow. 

                                        Combo Box Sample 
Combo boxes can be bound or unbound controls. These controls can look up values in a fixed list that 
you type yourself, or they can look up values in a table or query. 
Definition: A combo box is an object or control found on a Form in Microsoft Access. It is a drop-down list 
of values that the user can select from. You can set up the combo box to restrict the user's selection to 
the items in the list. Or you can allow the user to enter a value that is not contained in the list as well as 
select an item from the list. 
Combo boxes generally serve the following purposes:- 

1. Standardize the values that a user can enter, since the user is presented with a list of values to 
choose from. 

2. Make user selections faster and easier. 
3. Allow the user to view multiple columns within a single combo box, providing a vast amount of 

information at a single glance. 
Creating a Combo Box that Looks Up Values 

1. Open the form in Design View 
2. Choose the Combo Box command in the Controls group on the Form Design Tools Design 

Contextual tab 
3. Click and drag to draw the Combo Box on your form 



    
4. Choose “I want the combo box to look up the values in a table or query.” 
5. Click Next. 

  
6. Select the Table or Query that contains the values you want to look up 
7. Click Next. 

Combo Box Wizard - 
Choose Combo Box 
Option 

Combo Box Wizard - 
Choose a Table or Query 



 
8. Move the fields you want to appear in your lookup list from the Available Fields column to the 

Selected Fields column 
9. Click Next. 

 
10. Choose a Sort order, if desired 
11. Click Next. 

Combo Box Wizard - Choose 
Combo Box Fields 

Combo Box Wizard - Choose 
Sort Order 



 
12. Resize the Combo Box columns 
13. Click Next 

 
14. Choose to store the value in a primary key in the record source 
15. Click Next 

Combo Box Wizard - Resize 
Combo Box Columns 

Combo Box Wizard - Choose 
Primary Key Field 



 
16. Enter a Name for your combo box 
17. Click Finish 
18. Save the form 
19. View the form in Form View 
20. Test the new Combo Box 

 
 
Creating a Combo Box for Values You Enter 

1. Open the form in Design View 
2. Choose the Combo Box command in the Controls group on the Form Design Tools Design 

Contextual tab 
3. Click and drag to draw the Combo Box on your form. 

Combo Box Wizard - Create a 
Name 

Combo Box Sample 



 
4.   Choose “I will type in the values that I want” 
5. Click Next. 

 
6. Enter the combo box values 
7. Resize the column 
8. Click Next 

Combo Box Wizard - Choose 
Combo Box Option 

Combo Box Wizard – Enter 
Combo Box Values 



 
9. Choose to remember the value for later use 
10. Click Next 

 
11. Enter a Name for your combo box 
12. Click Finish 
13. Save the form 
14. View the form in Form View 
15. Test the new Combo Box 

        
 

 

Combo Box Wizard – Remember 
the Value 

Combo Box Wizard - Create a 
Name 

Combo Box sample 



SQL View 
Whenever you create a query in query design, Access automatically creates the SQL query for you. This 
actually retrieves data from the tables. To see how your query is created in sql when you create it in 
query design, let us open your database. 
To view the SQL for a query in Access 2007 : 

1. Open the query in Design View. To do this, right-click on the Query in the left window and select 
Design View from the popup menu. 

2. Next, select the Design tab in the toolbar at the top of the screen. Then click on the View button 
in the Results group. Select SQL View from the popup menu. 

3. You can see the SQL query which is generated by Access automatically. This helps retrieve data 
from two tables. 

MS Access – Formatting 
One especially useful formatting tool in Access is the ability to apply Conditional Formatting to highlight 
specific data. 
Data on forms or reports in Access desktop databases can sometimes appear easier to read especially 
when you highlight the really important areas. That’s where conditional formatting can help. In an Access 
desktop database, you can set rules to controls so that the values are automatically highlighted. 
To apply this particular conditional formatting rule to a date field in a form, do the following: 

1. Open the form in Design view. 
2. Select the date field. 
3. Click the contextual Format tab. 
4. Click Conditional Formatting in the Control Formatting group. 
5. In the resulting dialog, click New Rule. 
6. The Select A Rule Type option will default to the right option, Check Values In The Current 

Record Or Use An Expression, so don't change that option. 
7. Now you're ready to define the rule. Field Value Is is the appropriate option in the first dropdown 

control, so don't change it. 
8. Choose Less Than Or Equal To from the second dropdown. 
9. Enter the following expression: Now()+7. (That period is grammatical and not part of the 

expression.) 
10. From the Font Color dropdown, choose any color. 
11. Click OK. Your form should resemble the one shown above in form View. 


